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OVERVIEW 

“Let’s build something together” 
Get the right tools for the right project. 
Workshop outline: 
Part I: 

 Your materials (data) 
 Your project (research questions) 
 Your tools (analysis methods) 
 Which tools to use for which projects 

Part II: 
Practice in SPSS 
"Comparing motivations for shopping at Farmer’s markets, CSA’s, or 
neither.“ 
 



INDIANA STATISTICAL CONSULTING CENTER 

 What kind of analysis should I use to answer my 
research questions? 

 What is the statistical output telling me about me 
data? 

 How do I address the reviewer’s comments about 
the stats in the manuscript I submitted?  

Consultations by appointment:  
SSRC in Woodburn 200: M-F 9-12  
Scholars Commons in Wells: Mon 2-4, Wed 11-1 

“You can build it. We can help.” 
http://www.indiana.edu/~iscc 
iscc@indiana.edu 
  
Free consultation, Funded Collaboration, & Educational Outreach 



DIY RESOURCES 

At IU: 
 Stats courses http://statclasses.indiana.edu  
 Research Analytics (UITS) - software support 

http://rt.uits.iu.edu/visualization/analytics/ 
 WIM/ISCC workshops: http://ssrc.indiana.edu/seminars/wim.shtml  
 UITS training http://ittraining.iu.edu/training (SPSS, SAS,...) 
On the web: 
 UCLA Stats Consulting http://www.ats.ucla.edu/stat/  
Books: 
 Discovering Statistics Using SPSS, by Andy Field 

http://statclasses.indiana.edu/
http://rt.uits.iu.edu/visualization/analytics/
http://ssrc.indiana.edu/seminars/wim.shtml
http://ittraining.iu.edu/training
http://www.ats.ucla.edu/stat/


SOFTWARE 

 SPSS – easy “point & click”, good for most “off the shelf” analyses 
 STATA – syntax w “point & click”- political science, sociology,… 
 SAS – syntax - industry standard, public health,… 
 R – free & flexible (but less documented and maintained) 
 MATLAB – powerful numerical computing, matrix manipulations 

 IUanyWare.iu.edu 
Free software, streaming online 
 

 cloudstorage.iu.edu  
 Box.iu.edu 
 File server 



MATERIALS 



DATA TYPES 
Data Type Examples 

Continuous/  
Interval/ 
Scale 
 

Test score 
Height, weight, age 
Response Time 
<Percent, proportions > 
<Likert-type scales> 
<Counts> 

Ordinal Educ: Bachelor, Masters, PhD. 
Likert-type scales 

Categorical: 
Nominal (≥2) 
Binary (2 levels) 

Treatment Group (A,B,C) 
Sex: Male/female, 
Yes/no, right/wrong, 0/1. 



DATA CONSIDERATIONS 

NOTE: It’s one thing to know the TRUE nature of the data (Continuous, Categorical, 
Ordinal), but it may be a separate decision how you will TREAT the data in a 
particular analysis. 

Ex: Likert-type Scale (1 to 5) may be truly Ordinal (i.e. not truly continuous/interval) 
but usually needs to be treated as Categorical or Continuous for standard analyses 

There is not a clear “recipe” or a “one-size fits all” for these decisions…  

What is meaningful for your data analysis? ... 

 Are you willing to assume a straight linear relationship across the scale 
(continuous… as age goes up, blood pressure goes up),  

 or do you want to fit separate means for each discrete level (categorical 
…average blood pressure for separate age groups)? 



INDEPENDENT OBSERVATIONS? 

…if each observation is a random “independent” 
draw from the larger population. 
Only one measure for each person in the analysis 
Important to know the structure because: 
 Most standard analyses (T-test, ANOVA,  

Regression, Chi-square,…) assume 
independent observations.  

 This assumption is built in to the calculation of 
the p-value for “significant” inferences. 



CORRELATED DATA 

 Multiple measurements within subject across 
 time, condition, or item (Repeated Measures) 

 Observations are clustered in groups (Random 
effects/HLM) 
 Students within class, class within school  
 Mice within litters 
 Plants within plots 

 



…REPEATED MEASURES 
ID Group Week1 Week2 Week3 
1 Trt 142 139 120 
2 Control 155 156 135 
3 Trt 151 149 150 
Etc… 

ID Group Week Sys BP 
1 Trt 1 142 
1 Trt 2 139 
1 Trt 3 120 
2 Control 1 155 
2 Control 2 156 
2 Control 2 135 
Etc 

“long” format 

“wide” format 



…RANDOM EFFECTS (CLUSTERED)  

ID School Treatment Math Reading 

1 A Trt 256 189 

2 A Trt 213 178 

3 B Cntrl 354 210 

4 C Trt 187 190 

5 B Cntrl 210 221 

6 D Cntrl 185 196 

Etc… 

 Subjects are clustered within school 

 May need random effect for School… 



TOOLS 



EXAMPLE 

Local Food in Indiana 
Comparing consumers 
(n=302) who purchase food 
at Farmer’s Markets, CSA’s, 
or neither, in their 
motivations towards local 
food. 

 



SURVEY 



DATA 
SPSS Data View 
 Columns are ‘Variables’ 

 Rows are subjects, or ‘Observations’ 



VARIABLES 
SPSS Variable View 



DESCRIBING AND EXPLORING 



DESCRIBING 

Continuous Variables  
 Histograms, QQ-plot 
 Descriptive Stats (Mean, SD, Median, Min, Max) 

Most analyses (T-test, ANOVA, 
Regression, etc) prefer a Normal 
(bell-shaped), symmetric 
distribution… 



Categorical Variables 
 Frequency tables: Counts & Percentages 



DATA CLEANING 
 Re-codes, grouping 
 Transformations (Log, square-root, etc)  
 Summary scores 
 Re-structure 

 A 
A 
B 
 

A 
A 
A 
C 
A 
B 
B 
B 
B 
B 

Organic, 
Whole, 

Humane 

Fresh, 
Local,  

In season 

Expensive 

Created 3 summary 
scores by averaging 
across responses in 
correlated items. 



1 Continuous w/ 1 Categorical variable 
 Comparison of Means 
 Boxplots 

A box-plot 
is kind-of a 
histogram 
on its side. 

Comparing 2 groups… 
Think about T-test… 

EXPLORING 



3 or more groups… 
Think about ANOVA… 



2 Continuous variables 
 Correlation 
 Scatterplot 

Think about  
Pearson correlation… 



2 Categorical variables 
 Crosstabs 
 Comparison of Proportions 

 

Think about Pearson 
Chi-square test… 



MAKING PLANS 



GENERAL LINEAR MODELS 

…The set of tools for modeling one (or more) outcome(s)  
 (Y) as a function of one or more predictors (X). 

Dependent Variable (DV) = the outcome measure (Y) 

Independent Variable (IV) = the predictor variable(s) (X’s) 

Y = α + β1 X1 + β2 X2 + β3 X3 +…+ ε 

 

 A framework for ANOVA, Regression, etc 

 Can be used hypothesis tests for research questions: 
 Is there a difference between groups (sex (X1)) in some variable (height (Y))? 

 Is there an association between one variable (tree density (X1)) on some 
outcome (seedling density (Y)), controlling for other covariates (X2, etc)? 



DV Data structure Analyses Model type 
DV is Continuous Independent 

Observations 
  

T-test, Correlation, 
ANOVA, ANCOVA, 
Repeated Measures ANOVA, 
Linear Regression. 

General Linear Model 
  

DV is Continuous Correlated Data  
  

“Mixed” Models. 
Repeated Measures. 
Random Effects (HLM). 

General Linear Mixed 
Model 
  

DV is Categorical  Independent 
Observations 

Crosstab, Pearson Chi-square. 
Logistic Regression. 
Poisson, Neg. Binomial. 

Generalized Linear 
Model 
  

DV is Categorical  Correlated Data  
  

Repeated Measures Logistic 
Regression. 
GEE, GLIMMIX 
  

Generalized Linear 
Mixed Model 
  

Which bucket of tools do you use with given materials? 



DV IV Analyses 
DV is Continuous IV is Categorical 

  
T-test (1 IV: 2 groups (Binary)),  
One way ANOVA (1 IV: >2 groups), 
Two-way ANOVA (2 IV’s) 
Factorial ANOVA (>2 IV’s) 

IV is Continuous 
  

Pearson Correlation (1 IV) 
Simple Linear Regression (1 IV) 
Multiple Linear Regression (>1 IV) 

Any IV’s ANCOVA 
Multiple Linear Regression 

Multiple DV’s  
(Continuous) 

Paired T-test (1 IV, 2 levels) 
Repeated Measures ANOVA (≥2 levels) 
MANOVA (≥2 DV’s) 

DV is Counts Any IV’s 
 

Poisson Regression 
Neg. Binomial Regression.  

DV is Categorical  
 

IV is Categorical Pearson Chi-square (1 IV). 
Logistic Regression (>1 IV). 

2 levels Any IV’s Binary Logistic Regression 

>2 levels Any IV’s 
 

Multinomial Logistic Regression 

…zooming in on Independent Observations 



What’s the difference between ANOVA and Regression? 
 More about a matter of perspective - experimental design vs observational data 
 Mathematically, the model for an ANCOVA (1 categorical IV with 1 continuous 

“covariate”) is the same as a Regression with 1 categorical IV and 1 continuous 
IV. You’ll get the same results. 

 A “covariate” is just another Independent Variable. 
 ANOVA often includes factorial interactions between IV “factors”, but it’s really 

up to you… 
 Software for “ANOVA” and “Regression” usually have different defaults, but you 

can always get one from the other. And “GLM” does both! 
 ANOVA often includes interactions, shows sums of squares with F tests 
 Regression will not include interactions by default, shows beta parameter 

coefficients 
 

“Identical Cousins” 



ASSUMPTIONS 

Assumptions of GLM (T-test, ANOVA, Regression) 
 Observations are independent (or else modeled appropriately in a Repeated 

Measures or “Mixed” model) 
  There are equal variances between the groups (or across values of 

continuous predictor variables). 
 Evaluate standard deviation in each group 

 boxplots or scatterplot of DV vs IV 

 Maybe use Levene’s test for homogeneity of variance 
 Residuals have equal variance across levels of IV’s 

  Residuals are Normally distributed. 
 Normally distributed DV is a ‘proxy’ for this… 
 Inspect histogram, qq-plot, skewness, and kurtosis; boxplot 
 Shapiro-Wilks tests normality, but p-value not always helpful… 

 



 Not independent observations? 
 Maybe aggregate data to the individual level? (esp. binary data!) 
 Model the correlation structure in Repeated Measures ANOVA or Mixed Models 

  Not equal variances?  
 Levene’s test is only one diagnostic measure… (careful with p-values) 
 What is Std. Dev. in each group? How different are they? Is one more than twice as big as the 

other? 
 If sample sizes between groups are equal, ANOVA is robust to this 
 Log transformations of skewed data often help with variances  

 Not Normally distributed DV/residuals? 
 Be skeptical of tests of normality (Shapiro-Wilks)…p-value is more significant with larger sample 

size, but…but larger sample sizes are more robust (Central Limit Theorem means ANOVA is 
Robust) 

 Skewness and Kurtosis are helpful (skewness <1 or 2?) 
 Try transformations, like taking the log, square root (or try Box-Cox) 

When assumptions are (or seem to be) violated 



When assumptions are (or seem to be) violated 

How bad is too bad? 
 “Consequences of Failure to Meet Assumptions Underlying the Fixed 

Effects Analyses of Variance and Covariance”, Glass, Peckham and 
Sanders. 1972 42: 237 REVIEW OF EDUCATIONAL RESEARCH  

 
 Non-parametric tests where possible: 

 Wilcoxon Rank-sum (comparing 2 groups; T-test) 
 Kruskal-Wallis (comparing 3 groups; One way ANOVA) 
 A little less powerful. 
 Still assume independent observations. 
 More robust 

 Or bootstrap your own p-values… 
 



PUTTING IT IN PRACTICE 



SPSS 

Note that I am not particularly promoting SPSS over other 
stats software except that it’s the easiest to pick up and use 
quickly. 
 
If you don’t have a copy of SPSS locally, use 
IUanyware.IU.edu  

 Install Citrix client first 
 

Open the CSA Farmer’s 
 Market data… 
https://iu.box.com/ISCCWorkshops  

https://iu.box.com/ISCCWorkshops


DESCRIPTIVES 

For descriptive stats and exploratory plots  
 Analyze > Descriptive Stats > Descriptives (Select ‘Organic’ as Variable) 
 Graphs > Legacy > Histogram (Select ‘Organic’ as Variable) 
 Graphs > Legacy > Boxplot > Simple (Select ‘Organic’ as Variable, and Gender as 

‘Category Axis’) 
 Analyze > Compare Means > Means (Select ‘Organic’ as ‘Dependent’, and Gender as 

‘Independent’) 
 Graphs > Legacy > Scatter/Dot > Simple Scatter (Select ‘Organic’ as Y-Axis and 

‘Local’ as X-Axis) 
 Analyze > Correlate > Bivariate (Select ‘Organic’ and ‘Local’) 
 



T-TEST 
 (Independent Samples) 
 Compare Continuous DV between 2 groups (1 Categorical IV w/ 2 levels) 
Is there a difference between men and women in how highly they rate the importance of 
buying Organic/Whole food? 
IV: Gender (M/F) 
DV: Organic 



…T-test in SPSS 
Analyze > Compare Means > Independent Samples T-Test 
 Put DV (Organic) in the ‘Test Variable(s)’. 
 Put IV (Gender) in the Grouping Variable. Define Groups 1 and 2. 
Output: 
 Inspect Descriptive Stats. 
 Check Levene’s test. 
 Use corresponding “Sig.” value (= p-value) 
 
There is not a significant difference between males and females in how important 
organic food is to them. 
 

T-TEST 



 Compare Continuous DV between 3 or more groups (1 Categorical IV w/ 3+ levels) 
 
Is there a difference between the three venues in how highly respondents rate the 
importance of buying Organic/Whole food? 
 
IV: Venue (CSA, Farmer’s Market, neither) 
DV: Organic 
 
(note box-plot above) 

ANOVA 



…One-way ANOVA in SPSS 
 
Analyze > Compare Means > One-way ANOVA 
 Put DV (Organic) as ‘Dependent’, and Venue as ‘Factor’ 
 ‘Post Hoc’ > Tukey 
 Options > Descriptives and Homogeneity of variance. 
 
Output: 
 Inspect Descriptive Stats. 
 Check Levene’s test. 
 Use “Sig.” value (= p-value) from ANOVA table 
 
There is a significant difference between the three venues in how respondents rate Organic food 
(F(2,301)=29.9, p<.001). CSA members give the highest ratings for the Organic/Whole/Animal 
items (M=4.35, SE=.05), followed by the Farmer’s Market participants (M=4.04, SE=.06), and lastly 
those who use neither (M=3.5, SE=.10). All pairwise differences are significant (Tukey, p’s <.001). 

Note! 

Post-hoc tests (comparing trt 1 
vs 2, 1 vs 3, and 2 vs 3) are 
begging for a p-value 
“correction” so that you don’t 
over-test your data. 

Bonferroni is easy (takes p-value 
times # of comparisons, or 
alpha/comparisons) but too 
conservative/stingy.  
Tukey is more accurate. 

ANOVA 



For more than one Categorical IV… 
 
Is there a difference between the three venues AND by income in how highly 
respondents rate the importance of buying Organic/Whole food? 
 
IV: Venue (CSA, Farmer’s Market, neither); Income levels 
DV: Organic 

ANOVA 



…GLM in SPSS 
Analyze > General Linear Model > Univariate 
 Put DV (Organic) as ‘Dependent’. 
 Put Gender and Income as ‘Fixed Factors’.  
 Click ‘Model’ to specify interactions. 

(“ANOVA” usually thinks about interactions…) 
 Post Hoc > Tukey 
 (Optional) Save > Standardized Residuals 
 Options > Display Means for: Gender Income Gender*Income 

(Note: ‘Compare main effects’ can do Bonferroni or Sidak, but Tukey not an option here) 
(Optional) Get ‘Descriptive Stats’, ‘Estimates of effect size’, ‘Homogeneity tests’ 

Output: 
 Tests of Between-Subjects Effects (F-tests & “sig” p-values) 
 Estimated Marginal Means 
 Post-hoc tests 

 

ANOVA 
SPSS note! 

‘Fixed Factors’ are for 
Categorical variables. 

‘Covariates’ are for 
Continuous variables. 



“Factors” vs “Covariates” in GLM 
 In SPSS, “Factors” are any categorical IV. “Covariates” are any continuous IV. 
 Regression procedure only permits continuous variables or dummy (0/1) 
 In SAS, the “Class” statement is for any categorical IV. Others are continuous.  
 Your model will be “wonky” to say the least if you mix them up... 
 Do Random effects in Linear Mixed Model rather than ANOVA 
 

ANOVA 

Nominal IVs 

I DON’T RECOMMEND 
USING THIS BOX 

Continuous  IVs 



 Compare Continuous DV between groups (Categorical IV), adjusting for 
Continuous “covariate” IV 
 

What’s the difference in ‘Organic’ ratings between venues and gender, 
controlling for age? 
 
IV: Venue (CSA, FM, neither); Gender (M/F); Age 
DV: Organic 

ANCOVA 



… in SPSS 
 

Analyze > General Linear Model > Univariate 

 Put DV (Organic) as ‘Dependent’. 

 Put Venue and Gender as ‘Fixed Factors’.  

 Put Age as ‘Covariate’ 

 (other options same as above) 

 Also, Options > Parameter Estimates (to get ‘slope’ for continuous variables: age) 

Output: 

 Tests of Between-Subjects Effects (F-tests & “sig” p-values) 

 Parameter estimates for continuous variables 

 Estimated Marginal Means for categorical variables 

 Post-hoc tests for categorical variables  

ANCOVA 



 Compare more than 1 Continuous (related) DV between groups (Categorical 
IV), adjusting for Continuous “covariate” IV 

 
What’s the difference in all 13 of the food motivations by Venue and Gender, 
and adjusting for age? 
 
IV: Venue (CSA, FM, neither); Gender (M/F); Age 
DV: Item #1, 2, 3….13 (Q1MOTORGANIC, Q1MOTFEQCHEM, etc) 
 

MANOVA (OR MANCOVA) 



… in SPSS 
 
Analyze > General Linear Model > Multivariate 
 Put Q1MOTORGANIC, Q1MOTFEQCHEM, etc as ‘Dependent’. 
 Put Gender and Venue as ‘Fixed Factors’.  
 Put Age as ‘Covariate’ 
 (other options same as above) 
 
Output: 
 Multivariate Tests (the gatekeeper to individual ANOVA’s, p<.05?) 
 Tests of Between-Subjects Effects (F-tests & “sig” p-values) 
 Parameter estimates for continuous variables 
 Estimated Marginal Means for categorical variables 
 
Note (!) that the only difference between MANOVA and separate ANOVA’s is the omnibus 
“gatekeeper” tests first. The following “tests of between-subjects effects” are the same as if you 
had run separate ANOVA’s. 

MANOVA (OR MANCOVA) 



 Compare 2 Continuous DV’s “paired” within subject 
 

Do people rate the importance of buying organic food higher than the expense which 
might deter them?  

 

DV: Q1MOTORGANIC, Q1MOTEXPENSE  
IV: (NA)  

 

Or could call the DV the “rating” while the IV is the “motivation (A or B)” 

 

PAIRED T-TEST 



… in SPSS 
 
Analyze > Compare Means > Paired samples t-test 
 Put Q1MOTORGANIC and Q1MOTEXPENSE into ‘paired variables’  
 
Output: 
 Inspect Descriptive Stats and Mean difference 
 Find “Sig” level 

 
There is a significant difference (p<.001) where the respondents overall rated the 
organic motivation higher than the deterrent of the expense. 
 
However, what if you did the analysis separately by VENUE?... 
 Data > Split File > Compare groups by Venue 

 

PAIRED T-TEST 



 Compare multiple Continuous DV’s within-subject, and also IV’s between-subject 
 
Which motivation do people rate the highest: ‘Organic/Whole Food & Animals’ , ‘Local & 
Fresh’, or ‘Too expensive’? How does it depend on survey venue? 

 
DV: (Ratings of) Organic, Local, Expensive  
IV: Venue; ‘Motivation’ 
 
Note! ‘Motivation’ is not a variable in  
your dataset, but you will have to label 
the ‘within-subject’ variable defined  
by the three motivations. 
(See example in 2nd half) 

 

REPEATED MEASURES ANOVA 



… in SPSS 
Analyze > General Linear Model > Repeated Measures 
 Put ‘motivation’ as the Within-subject Factor, with 3 levels 
 (optional) Name the measure Ratings 
 Enter Organic, Local, Expensive as the ‘within-subject’ variables 
 Enter Venue as a ‘between-subject’ factor 
 Consider ‘Model’ or ‘Plots’ 
 ‘Post-Hoc’ for Trt, with Tukey 
 ‘Options’ > Display Means for everything 
Output: 
 Multivariate tests > Wilk’s lambda  
 Or, Tests of Within-subject effects > Sphericity assumed* 
 Tests of Between-subject effects 
 Estimated Marginal Means & Plots 

 

REPEATED MEASURES ANOVA 



REPEATED MEASURES ANOVA 
Results 
Both main effects and interaction 
are significant. 
 There is an overall difference 

between the 3 motivations. 
 There is an overall difference 

between the 3 venues. 
 The difference between the 

motivations is different across 
the venues. 

 



Repeated Measures ANOVA for Diet Study 
This is a hypothetical data file containing the results of a study of a hypothetical diet 
(loosely based on the "Stillman diet" (Rickman et al., 1974)). Each case corresponds to a 
separate subject, and records their weights in pounds and triglyceride levels in mg/100 
ml at five stages of the diet. 
We want to know if the patients’ weight (DV) decreases over time (IV, factor), and is 
weight-loss related to age (IV, covariate) and gender (IV, factor). 
 
 Data & Demo : https://iu.box.com/ISCCWorkshops  

 2014-09-01 Statistical Toolbelt folder 
 Diet Study Demos: 
 ‘dietstudy.sav’ – dataset 
 ‘Diet Study RM ANOVA_demo.pdf’ – slideshow for SPSS commands 

 

 

…More Practice 

https://iu.box.com/ISCCWorkshops


CORRELATION 

 Test for relationship between 2 Continuous variables (~IV & 1 
DV) 

 
What’s the correlation (or association/ relationship) between age 
and each of the three motivations? 

 Organic, Local, Expensive 
 



CORRELATION 

…in SPSS 
 
Analyze > Correlate > Bivariate 
 Enter Age and the three motivations (Organic, Local, Expensive). 
 Check Pearson and/or Spearman (Non-parametric test) 
 
Output: 
 Pearson r correlation value (or Spearman rho) 
 Corresponding p-value 
 Sample size (N) 
 
Note that the Pearson correlation (r) is the square root of the R-squared from a 
simple linear regression … 
 



REGRESSION 

Multiple Linear Regression 
 Test for effect of one (or more) predictor variables (IV: any type) 

on one Continuous outcome (DV) 
 

DV: Expensive 
IV’s: Venue, Age, Gender, Income, Education 



REGRESSION 

Linear Regression in SPSS 
 

 For continuous IV’s (or dummy variables 0/1): 
 Analyze > Regression > Linear 
 Note: ‘Method’: ‘Enter’ to enter all IV’s simultaneously, or ‘Stepwise’ selection 

 
 For continuous and categorical IV’s: 

 Analyze > General Linear Model > Univariate 
 Enter Age as a ‘covariate’ 
 Enter Gender as a ‘factor’ 
 (same options and output as above, but make sure you get Parameter Estimates) 
 Parameter estimates are what make it more ‘regression-like’. 
 Means and ‘forced’ interactions make it more ‘anova-like’. 
 Note: If we would enter ‘trt’ as a factor, this analysis would be identical to the 

ANCOVA above! 
 



CHI-SQUARE TEST 
Pearson Chi-square Test 
 Test for relationship between 2 Categorical vars, also a 

comparison of proportions 
 
What’s the difference in age group distribution between 
respondents in the three venues? 
 
Venue (CSA, FM, neither) 
Age group 

 



CHI-SQUARE TEST 
…in SPSS 
 
Analyze > Descriptive Stats > Crosstabs 
 Enter Income as ‘Rows’ and Venue as ‘Columns’ (or vice-versa) 
 Statistics > Chi-square 
 Cells > Percentages > Columns (or Rows) 
 Since we sampled by Venue, this will give the % in each age group by Venue. 
 
Output: 
 Frequencies & Percentages 
 ‘sig’ p-value from Pearson Chi-square 
 



LOGISTIC REGRESSION 
 Test for effect of any IV’s on 1 Categorical DV with 2 or more levels.  

 2 levels for DV (Yes/No) is Binary Logistic 
 3 or more levels for DV is Multinomial 

 
What variables are most “predictive” of your food shopping group (CSA, 
FM, neither) ?  
 
DV: Group (CSA, FM, neither) 
IV: Age, Gender, Race, Education, Income 

Beware! 
Multinomial (3+ 
groups) can be a 
BEAR to interpret!  



LOGISTIC REGRESSION 
…in SPSS 
 
Analyze > Regression > Multinomial [usually Binary] 
 Enter Venue as ‘Dependent’. 
 Enter Age, as ‘Covariates’; Gender, and Race as Factors 
 For Binary: if you have numeric categorical variables, enter as 

covariates and click ‘Categorical’ to specify. 
 Note: Method > ‘Enter’ or ‘Forward: LR’ 
 
Output: 
 DV Encoding (Predicting ‘1’ vs ‘0’) 
 Categorical variable coding (reference levels ‘0’) 
 Block 0 - Variables not in the Equation 
 Block 1 - Variables in the Equation 

 



LINEAR MIXED MODEL 
Correlated data… 
 
 Longitudinal data, Panel data, Hierarchical Linear Models 
 Data in “long” format 
 Better than RM ANOVA if missing data across repeated measures 
 Necessary if IV’s are also changing across repeated measures (“time varying covariates”) 
 
Repeated Measures 
 …if you can enumerate/items measurements across time or task 
 ex: each person is measured once a year for 5 years, or each person does 5 different 

tasks, or you measure response time for 32 different trials 
 
Random Effects 
 …if you cannot enumerate specific items but there is just a “bucket” of observations for 

each subject/group, then subject (or group) is the Random effect. 
 ex: students within class or school (HLM), words spoken by person 

 



LINEAR MIXED MODEL 
 
 

Example: Diet Study 
 Diet data is restructured into “long” form with multiple rows for each 

subject.(‘Dietstudy_long.sav’) 
 Note that under some circumstances the LMM on “long” data can be identical to the RM ANOVA 

on “wide” data. (‘time’ is categorical, no missing data, ‘compound symmetry’ correlation 
structure) 

 Data & Demo : https://iu.box.com/ISCCWorkshops  
 ‘2014-09-01 Statistical Toolbelt’ folder 
 ‘dietstudy_long.sav’ – dataset 
 ‘Diet Study LMM_demo.pdf’ – slideshow for SPSS commands 

 More info: 
 ‘2011-10-04 GLM Workshop’ folder 
 ‘GLM workshops slides Part 2 2011-10-03.pdf’ 
 UCLA stat computing http://www.ats.ucla.edu/stat/spss/library/spssmixed/mixed.htm 

 

…For Practice 

https://iu.box.com/ISCCWorkshops
http://www.ats.ucla.edu/stat/spss/library/spssmixed/mixed.htm


THE END 

 
 Please fill out the WIM feedback survey.  

 
 Let me know any questions: 

 Stephanie Dickinson (sd3@indiana.edu) 
 
 And let us know how we can help with your analyses: 
 
Indiana Statistical Consulting Center (ISCC) 
http://www.indiana.edu/~iscc 
 
 
 

mailto:sd3@indiana.edu
http://www.indiana.edu/~iscc
http://www.indiana.edu/~iscc
http://www.indiana.edu/~iscc
http://www.indiana.edu/~iscc
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